-->
当前位置:首页 > 题库 > 正文内容

7-2 复数类的运算 (20 分)

Luz4年前 (2021-03-08)题库2963
7-2 复数类的运算 (20 分)

根据以下代码段完善 ?? 处内容及程序内容,以实现规定的输出。

class Complex{
   public:
       Complex(double r=0, double i=0):real(r), imag(i){    }
       Complex operator+( ?? ) const;//重载双目运算符'+'
       Complex operator-=( ?? ); //重载双目运算符'-='
       friend Complex operator-( ?? ) const;//重载双目运算符'-'
       void Display() const;    private:        double real;        double imag;
};void Complex::Display() const{    cout << "(" << real << ", " << imag << ")" << endl;
}int main(){    double r, m;    cin >> r >> m;    Complex c1(r, m);    cin >> r >> m;    Complex c2(r, m);
   Complex c3 = c1+c2;
   c3.Display();
   c3 = c1-c2;
   c3.Display();
   c3 -= c1;
   c3.Display();    return 0;
}

输入格式:

输入有两行,分别为两个复数的实部与虚部。

输出格式:

按样例格式输出结果。

输入样例:

在这里给出一组输入。例如:

4 2
3 -5

输出样例:

在这里给出相应的输出。例如:

(7, -3)
(1, 7)
(-3, 5)
作者
陈晓梅
单位
广东外语外贸大学
代码长度限制
16 KB
时间限制
400 ms
内存限制
64 MB
#include <iostream>
using namespace std;
class Complex
{
	public:
		Complex(double r=0, double i=0):real(r), imag(i){	}
		Complex operator+(Complex c) const;
		Complex operator-=(Complex c); 
		friend const Complex operator-(Complex c1,Complex c2) ;
		void Display() const;
	private:
		double real;
		double imag;
};
Complex Complex::operator+ (Complex c)const{

return Complex(real+c.real,imag+c.imag);
}
Complex Complex::operator-=(Complex c){
this->imag=this->imag-c.imag;
this->real=this->real-c.real;
return *this;
 
}
const Complex operator-(Complex c1,Complex c2){
c1.imag=c1.imag-c2.imag;
c1.real=c1.real-c2.real;
return c1;
}
 
void Complex::Display() const
{
	cout << "(" << real << ", " << imag << ")" << endl;
}
 
int main()
{
	double r, m;
	cin >> r >> m;
	Complex c1(r, m);
	cin >> r >> m;
	Complex c2(r, m);
	Complex c3 = c1+c2;
	c3.Display();
	c3 = c1-c2;
	c3.Display();
	c3 -= c1;
	c3.Display();
	return 0;
}


发表评论

访客

◎欢迎参与讨论,请在这里发表您的看法和观点。