函数题:CPoint类的构造与析构
定义一个CPoint类,代表平面上的一个点,其横坐标和纵坐标分别用x和y表示,要求在类的外部实现CPoint类的构造函数、复制构造函数和析构函数。
### CPoint类定义:
c++
class CPoint{
private:
int x,y;
public:
CPoint(int xx,int yy);
CPoint(CPoint &p);
~ CPoint();
int get_x() {return x;}
int get_y() {return y;}
};
/* 请在这里填写答案 */
其中 x , y 表示点的横坐标和纵坐标。
### 裁判测试程序样例:
c++
#include <iostream>
using namespace std;
void main()
{ int s,t;
cin>>s>>t;
CPoint A(s,t);
CPoint B(A);
cout << B.get_x()<<" "<< B.get_y()<<endl;
}
### 输入样例:
输入一个点的x和y坐标
in
10 20
### 输出样例:
out
Constructor
Copy constructor
10 20
Destructor
Destructor
答案:若无答案欢迎评论
构造函数:完成本类数据的赋值,根据输出结果需要输出字符串Constructor<br>
拷贝构造函数:完成逐域互拷,根据输出结果需要输出字符串Copy constructor<br>
析构函数:根据输出结果需要输出字符串Destructor
### CPoint类定义:
c++
class CPoint{
private:
int x,y;
public:
CPoint(int xx,int yy);
CPoint(CPoint &p);
~ CPoint();
int get_x() {return x;}
int get_y() {return y;}
};
/* 请在这里填写答案 */
其中 x , y 表示点的横坐标和纵坐标。
### 裁判测试程序样例:
c++
#include <iostream>
using namespace std;
void main()
{ int s,t;
cin>>s>>t;
CPoint A(s,t);
CPoint B(A);
cout << B.get_x()<<" "<< B.get_y()<<endl;
}
### 输入样例:
输入一个点的x和y坐标
in
10 20
### 输出样例:
out
Constructor
Copy constructor
10 20
Destructor
Destructor
答案:若无答案欢迎评论
构造函数:完成本类数据的赋值,根据输出结果需要输出字符串Constructor<br>
拷贝构造函数:完成逐域互拷,根据输出结果需要输出字符串Copy constructor<br>
析构函数:根据输出结果需要输出字符串Destructor