-->
当前位置:首页 > 题库 > 正文内容

编程题:jmu-Java-06异常-01-常见异常

Luz2年前 (2022-12-13)题库2088
自行编码产生常见异常。

## main方法

1. 事先定义好一个大小为5的数组。
2. 根据屏幕输入产生相应异常。

**提示:**可以使用System.out.println(e)打印异常对象的信息,其中e为捕获到的异常对象。

## 输入说明:

1. arr 代表产生访问数组是产生的异常。然后输入**下标**,如果抛出ArrayIndexOutOfBoundsException异常则显示,如果不抛出异常则不显示。
2. null,产生NullPointerException
3. cast,尝试将String对象强制转化为Integer对象,产生ClassCastException。
4. num,然后输入字符,转化为Integer,如果抛出NumberFormatException异常则显示。
5. 其他,结束程序。


### 输入样例:
in
arr 4
null
cast
num 8
arr 7
num a
other


### 输出样例:
out
java.lang.NullPointerException
java.lang.ClassCastException: class java.lang.String cannot be cast to class java.lang.Integer (java.lang.String and java.lang.Integer are in module java.base of loader 'bootstrap')
java.lang.ArrayIndexOutOfBoundsException: Index 7 out of bounds for length 5
java.lang.NumberFormatException: For input string: "a"






答案:若无答案欢迎评论

评论列表

无情的AI编程机器
无情的AI编程机器
12个月前 (01-24)

import java.util.Scanner;
public class Main {
public static void main(String[] args) {
Scanner scanner = new Scanner(System.in);
int[] array = new int[5]; // 定义一个大小为5的数组
while (scanner.hasNext()) {
String input = scanner.next();
try {
switch (input) {
case "arr":
int index = scanner.nextInt();
System.out.println(array[index]); // 尝试访问数组的给定索引
break;
case "null":
Object obj = null;
System.out.println(obj.toString()); // 尝试调用一个null对象的方法
break;
case "cast":
Object str = "test";
Integer num = (Integer) str; // 尝试将String对象转为Integer对象
break;
case "num":
String value = scanner.next();
In

发表评论

访客

◎欢迎参与讨论,请在这里发表您的看法和观点。